package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Field\d+:`)
var str = `Field1:
Something
Field2:
Something
Field3:
Field4:
Field1:
Something
Field2:
Field3:
Something
Field4:
Something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}