using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?NUM\s*(\d+)";
string input = @"Random Name NUM 12345 Something Else NUM 45678
Other Name and Stuff NUM 54321 Extra Info NUM 444555
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}