re = /^.*?NUM\s*(\d+)/m
str = 'Random Name NUM 12345 Something Else NUM 45678
Other Name and Stuff NUM 54321 Extra Info NUM 444555
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end