// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?NUM\s*(\d+)").unwrap();
let string = "Random Name NUM 12345 Something Else NUM 45678
Other Name and Stuff NUM 54321 Extra Info NUM 444555
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}