using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([a-z]*)( [a-z]*(=[a-z]*|="".*?"")?)*(\/>|>((?R)|[^<>]*)*<\/\1>)|";
string input = @"<html></html>
<html><a x>link<br/></a><p>Hi There</p></html>
<html><body class=main tag><img src=""foo bar baz""></img></body></html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}