re = /<([a-z]*)( [a-z]*(=[a-z]*|=".*?")?)*(\/>|>((?R)|[^<>]*)*<\/\1>)|/m
str = '<html></html>
<html><a x>link<br/></a><p>Hi There</p></html>
<html><body class=main tag><img src="foo bar baz"></img></body></html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end