import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([a-z]*)( [a-z]*(=[a-z]*|=\".*?\")?)*(\\/>|>((?R)|[^<>]*)*<\\/\\1>)|";
final String string = "<html></html>\n"
+ "<html><a x>link<br/></a><p>Hi There</p></html>\n"
+ "<html><body class=main tag><img src=\"foo bar baz\"></img></body></html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}