package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(-?[1-8]?\d(?:\.\d{1,18})?|90(?:\.0{1,18})?),\s*?(-?(?:1[0-7]|[1-9])?\d(?:\.\d{1,18})?|180(?:\.0{1,18})?)$`)
var str = `47.338388, 0.990228
-47.338388, -0.990228
47.338388,0.990228
-47.338388,-0.990228`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}