re = /^(-?[1-8]?\d(?:\.\d{1,18})?|90(?:\.0{1,18})?),\s*?(-?(?:1[0-7]|[1-9])?\d(?:\.\d{1,18})?|180(?:\.0{1,18})?)$/mi
str = '47.338388, 0.990228
-47.338388, -0.990228
47.338388,0.990228
-47.338388,-0.990228'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end