const regex = /^(-?[1-8]?\d(?:\.\d{1,18})?|90(?:\.0{1,18})?),\s*?(-?(?:1[0-7]|[1-9])?\d(?:\.\d{1,18})?|180(?:\.0{1,18})?)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?[1-8]?\\d(?:\\.\\d{1,18})?|90(?:\\.0{1,18})?),\\s*?(-?(?:1[0-7]|[1-9])?\\d(?:\\.\\d{1,18})?|180(?:\\.0{1,18})?)$', 'gmi')
const str = `47.338388, 0.990228
-47.338388, -0.990228
47.338388,0.990228
-47.338388,-0.990228`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}