using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({.*(?={))(.*(?<=.*}))(?:.*)}(.*)";
string input = @"The sentense { he said ""hello, {somebody}"" } got a something.
The sentense he said ""hello, {somebody}"" } got a something.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}