re = /({.*(?={))(.*(?<=.*}))(?:.*)}(.*)/
str = 'The sentense { he said "hello, {somebody}" } got a something.
The sentense he said "hello, {somebody}" } got a something.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end