$re = '/({.*(?={))(.*(?<=.*}))(?:.*)}(.*)/';
$str = 'The sentense { he said "hello, {somebody}" } got a something.
The sentense he said "hello, {somebody}" } got a something.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);