using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\S\s]*?)(?:@\s|$)";
string substitution = @"$1\n";
string input = @"Student @ Codey @ Huntting
Student @ Sarah @ Honsinger";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}