// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\S\s]*?)(?:@\s|$)").unwrap();
let string = "Student @ Codey @ Huntting
Student @ Sarah @ Honsinger";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}