const regex = /([\S\s]*?)(?:@\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\S\\s]*?)(?:@\\s|$)', 'gm')
const str = `Student @ Codey @ Huntting
Student @ Sarah @ Honsinger`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);