import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z0-9-_]+).txt:\\s?\\s?([A-Z0-9-_:]+)\\s+(\\d+:\\d+)|([A-Z0-9-_]+).txt:\\s+(\\w{6})\\s+(\\d+:\\d+)";
final String string = "RTARSPO0302.txt:MVNO_AMERICANET 26615:20891087 \n"
+ "RTARSPO0302.txt: import 26615:30150 IPV4 Unicast \n"
+ "RTARSPO0302.txt: import 26615:30200 IPV4 Unicast \n"
+ "RTARSPO0302.txt:RAN_SHARING_OI 26615:20302087 \n"
+ "RTARSPO0302.txt: import 26615:30200 IPV4 Unicast \n"
+ "RTARSPO0302.txt: import 26615:30206 IPV4 Unicast \n"
+ "RTARSPO0302.txt: import 26615:30301 IPV4 Unicast \n"
+ "RTARSPO0302.txt: import 26615:30320 IPV4 Unicast \n"
+ "RTARSPO0302.txt: export 26615:30301 IPV4 Unicast \n"
+ "RTARSPO0302.txt: export 26615:303027 IPV4 Unicast \n"
+ "RTARSPO0302.txt:TIMGPRS 26615:20203087 \n"
+ "RTARSPO0302.txt: import 26615:30200 IPV4 Unicast \n"
+ "RTARSPO0302.txt: import 26615:30301 IPV4 Unicast \n"
+ "RTARSPO0302.txt: export 26615:30200 IPV4 Unicast \n"
+ "RTARTSA0101.txt:DCN 26615:20705093 \n"
+ "RTARTSA0101.txt: import 26615:30700 IPV4 Unicast \n"
+ "RTARTSA0101.txt: export 26615:30700 IPV4 Unicast \n"
+ "RTARTSA0101.txt:RAN_SHARING_OI 26615:20301093 \n"
+ "RTARTSA0101.txt: import 26615:30301 IPV4 Unicast \n"
+ "RTARTSA0101.txt: export 26615:30301 IPV4 Unicast \n"
+ "R";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}