re = /([A-Z0-9-_]+).txt:\s?\s?([A-Z0-9-_:]+)\s+(\d+:\d+)|([A-Z0-9-_]+).txt:\s+(\w{6})\s+(\d+:\d+)/
str = 'RTARSPO0302.txt:MVNO_AMERICANET 26615:20891087
RTARSPO0302.txt: import 26615:30150 IPV4 Unicast
RTARSPO0302.txt: import 26615:30200 IPV4 Unicast
RTARSPO0302.txt:RAN_SHARING_OI 26615:20302087
RTARSPO0302.txt: import 26615:30200 IPV4 Unicast
RTARSPO0302.txt: import 26615:30206 IPV4 Unicast
RTARSPO0302.txt: import 26615:30301 IPV4 Unicast
RTARSPO0302.txt: import 26615:30320 IPV4 Unicast
RTARSPO0302.txt: export 26615:30301 IPV4 Unicast
RTARSPO0302.txt: export 26615:303027 IPV4 Unicast
RTARSPO0302.txt:TIMGPRS 26615:20203087
RTARSPO0302.txt: import 26615:30200 IPV4 Unicast
RTARSPO0302.txt: import 26615:30301 IPV4 Unicast
RTARSPO0302.txt: export 26615:30200 IPV4 Unicast
RTARTSA0101.txt:DCN 26615:20705093
RTARTSA0101.txt: import 26615:30700 IPV4 Unicast
RTARTSA0101.txt: export 26615:30700 IPV4 Unicast
RTARTSA0101.txt:RAN_SHARING_OI 26615:20301093
RTARTSA0101.txt: import 26615:30301 IPV4 Unicast
RTARTSA0101.txt: export 26615:30301 IPV4 Unicast
R'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end