// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z0-9-_]+).txt:\s?\s?([A-Z0-9-_:]+)\s+(\d+:\d+)|([A-Z0-9-_]+).txt:\s+(\w{6})\s+(\d+:\d+)").unwrap();
let string = "RTARSPO0302.txt:MVNO_AMERICANET 26615:20891087
RTARSPO0302.txt: import 26615:30150 IPV4 Unicast
RTARSPO0302.txt: import 26615:30200 IPV4 Unicast
RTARSPO0302.txt:RAN_SHARING_OI 26615:20302087
RTARSPO0302.txt: import 26615:30200 IPV4 Unicast
RTARSPO0302.txt: import 26615:30206 IPV4 Unicast
RTARSPO0302.txt: import 26615:30301 IPV4 Unicast
RTARSPO0302.txt: import 26615:30320 IPV4 Unicast
RTARSPO0302.txt: export 26615:30301 IPV4 Unicast
RTARSPO0302.txt: export 26615:303027 IPV4 Unicast
RTARSPO0302.txt:TIMGPRS 26615:20203087
RTARSPO0302.txt: import 26615:30200 IPV4 Unicast
RTARSPO0302.txt: import 26615:30301 IPV4 Unicast
RTARSPO0302.txt: export 26615:30200 IPV4 Unicast
RTARTSA0101.txt:DCN 26615:20705093
RTARTSA0101.txt: import 26615:30700 IPV4 Unicast
RTARTSA0101.txt: export 26615:30700 IPV4 Unicast
RTARTSA0101.txt:RAN_SHARING_OI 26615:20301093
RTARTSA0101.txt: import 26615:30301 IPV4 Unicast
RTARTSA0101.txt: export 26615:30301 IPV4 Unicast
R";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}