#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((.*_.*){3,})|(^.*[.,:;'"*&+()\/\\^])(.{,3}|.{20,})"
Local $sString = "uytfvhjg" & @CRLF & _
"fhhgd3fhhffghjhfffhjjgfxvhjhffghaj " & @CRLF & _
"fhhgd_fh_ffghj_ffff" & @CRLF & _
"fhh-dfhhf/fghjhfffp" & @CRLF & _
"fhhgd3fhhffghjhfffh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")