$re = '/((.*_.*){3,})|(^.*[.,:;\'"*&+()\/\\\\^])(.{,3}|.{20,})/m';
$str = 'uytfvhjg
fhhgd3fhhffghjhfffhjjgfxvhjhffghaj
fhhgd_fh_ffghj_ffff
fhh-dfhhf/fghjhfffp
fhhgd3fhhffghjhfffh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);