// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((.*_.*){3,})|(^.*[.,:;'"*&+()\/\\^])(.{,3}|.{20,})"#).unwrap();
let string = "uytfvhjg
fhhgd3fhhffghjhfffhjjgfxvhjhffghaj
fhhgd_fh_ffghj_ffff
fhh-dfhhf/fghjhfffp
fhhgd3fhhffghjhfffh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}