package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0|1]?[0-9]?[0-9])\.([0|1]?[0-9]?[0-9])`)
var str = `000.12
000.00
000.000
23.23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}