$re = '/([0|1]?[0-9]?[0-9])\.([0|1]?[0-9]?[0-9])/m';
$str = '000.12
000.00
000.000
23.23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);