re = /([0|1]?[0-9]?[0-9])\.([0|1]?[0-9]?[0-9])/m
str = '000.12
000.00
000.000
23.23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end