package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/var\/log\/nginx\/access\_(?<string>\S+)\.log`)
var str = `/var/log/nginx/access_api-developer-dev.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}