$re = '/\/var\/log\/nginx\/access\_(?<string>\S+)\.log/m';
$str = '/var/log/nginx/access_api-developer-dev.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);