package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a[ \t\n]*href=")([A-z0-9:\/\-+\.%_\(\)?&]*)(")`)
var str = `a href="adfadfeareaeafe"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}