re = /(a[ \t\n]*href=")([A-z0-9:\/\-+\.%_\(\)?&]*)(")/m
str = 'a href="adfadfeareaeafe"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end