$re = '/(a[ \t\n]*href=")([A-z0-9:\/\-+\.%_\(\)?&]*)(")/m';
$str = 'a href="adfadfeareaeafe"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);