using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:[^""]|\b""\b)+""|\S+";
string input = @"""w1 w""2"" w3 | w4 w""5 ""w6 w7""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}