$re = '/"(?:[^"]|\b"\b)+"|\S+/';
$str = '"w1 w"2" w3 | w4 w"5 "w6 w7"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);