package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(?:[^"]|\b"\b)+"|\S+`)
var str = `"w1 w"2" w3 | w4 w"5 "w6 w7"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}