import re
regex = re.compile(r"(?<=^|\"\",)\"\"|\"\"(?=,\"\"|$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\"foo\",\"bar\"\n"
"\"baz\",\"qu\"\"ux\"\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)