const regex = /_([^ *]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_([^ *]*)', 'gm')
const str = `_price_range* _qty_val`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);