$re = '/_([^ *]*)/m';
$str = '_price_range* _qty_val';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;