using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[ěščřžýáíéóúůüöďťňa-z])(?=.*[ĎŇŤĚŠČŘŽÝÁÍÉÖÓÚŮÜA-Z])(?=.*\d)(?=.*[$@#$.,_§!()%*?&+~|{}:;<>])[ĎŇŤĚŠČŘŽÝÁÍÉÖÓÚŮÜA-Zěščřžýáíéóúůüöďťňa-z\d$@#$.,_§!()%*?&+~|{}:;<>]{8,}";
string input = @"WebCa,r§ol1*
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}