re = /^(?=.*[ěščřžýáíéóúůüöďťňa-z])(?=.*[ĎŇŤĚŠČŘŽÝÁÍÉÖÓÚŮÜA-Z])(?=.*\d)(?=.*[$@#$.,_§!()%*?&+~|{}:;<>])[ĎŇŤĚŠČŘŽÝÁÍÉÖÓÚŮÜA-Zěščřžýáíéóúůüöďťňa-z\d$@#$.,_§!()%*?&+~|{}:;<>]{8,}/m
str = 'WebCa,r§ol1*
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end