import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"])(?<!\\\\).*?\\1(*SKIP)(*FAIL)\n"
+ "|\n"
+ "(?|\n"
+ " (?P<comment>(?s)/\\*.*?\\*/(?-s))\n"
+ " |\n"
+ " (?P<comment>//.+)\n"
+ ")";
final String string = "<?\n"
+ "/* This is a comment */\n\n"
+ "cout << \"Hello World\"; // prints Hello World\n\n"
+ "/*\n"
+ " * C++ comments can also\n"
+ " */\n\n"
+ "cout << \"Hello World\"; \n\n"
+ "/* Comment out printing of Hello World:\n\n"
+ "cout << \"Hello World\"; // prints Hello World\n\n"
+ "*/\n\n"
+ "echo \"//This line was not a Comment, but ... \";\n"
+ "echo \"http://stackoverflow.com\";\n"
+ "echo 'http://stackoverflow.com/you can not match this line';\n"
+ "array = ['//', 'no, you can not match this line!!']";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}