# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(['"])(?<!\\).*?\1(*SKIP)(*FAIL)
|
(?|
(?P<comment>(?s)/\*.*?\*/(?-s))
|
(?P<comment>//.+)
)
"""
test_str = ("<?\n"
"/* This is a comment */\n\n"
"cout << \"Hello World\"; // prints Hello World\n\n"
"/*\n"
" * C++ comments can also\n"
" */\n\n"
"cout << \"Hello World\"; \n\n"
"/* Comment out printing of Hello World:\n\n"
"cout << \"Hello World\"; // prints Hello World\n\n"
"*/\n\n"
"echo \"//This line was not a Comment, but ... \";\n"
"echo \"http://stackoverflow.com\";\n"
"echo 'http://stackoverflow.com/you can not match this line';\n"
"array = ['//', 'no, you can not match this line!!']")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.