re = /(['"])(?<!\\).*?\1(*SKIP)(*FAIL)
|
(?|
(?P<comment>(?s)\/\*.*?\*\/(?-s))
|
(?P<comment>\/\/.+)
)/x
str = '<?
/* This is a comment */
cout << "Hello World"; // prints Hello World
/*
* C++ comments can also
*/
cout << "Hello World";
/* Comment out printing of Hello World:
cout << "Hello World"; // prints Hello World
*/
echo "//This line was not a Comment, but ... ";
echo "http://stackoverflow.com";
echo \'http://stackoverflow.com/you can not match this line\';
array = [\'//\', \'no, you can not match this line!!\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end