package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^<>{}]|<([^<>{}]|{[^<>{}]*})*>|{([^<>{}]|<[^<>{}]*>)*})*$`)
var str = `XXX<XX{X}XXX>X
X{X}X<X>X{X}X<X>X
XXX<X<XX>>XX
XX<XX{XX>XX}XX
XX<XX{XX>XXXX
XX<XX{XX{XX}XX}XX>XX
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}