re = /^([^<>{}]|<([^<>{}]|{[^<>{}]*})*>|{([^<>{}]|<[^<>{}]*>)*})*$/m
str = 'XXX<XX{X}XXX>X
X{X}X<X>X{X}X<X>X
XXX<X<XX>>XX
XX<XX{XX>XX}XX
XX<XX{XX>XXXX
XX<XX{XX{XX}XX}XX>XX
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end