import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\"[^\"]*?\"|'[^']*?'|[^'\">])*>";
final String string = "re<br>na<br>to<br>galvao\n\n"
+ "<div id=\"mainmenu\">\n"
+ " <ul class=\"menu root\">\n"
+ " <li class=\"item selected\" title=\"Regex Tester\"><a href=\"/\">Regex Tester</a></li>\n"
+ " <li class=\"item \" title=\"Community\"><a href=\"/community/\">Community</a></li>\n"
+ " <li class=\"item \" title=\"Regex Quiz\"><a href=\"/quiz/\">Quiz</a></li>\n"
+ " <li class=\"item \" title=\"Join us on IRC!\"><a href=\"/irc/\">Join us on IRC</a></li>\n"
+ " <li class=\"item \" title=\"About & Credit\"><a href=\"/about/\">About & Credit</a></li>\n"
+ " </ul>\n"
+ " </div>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}