import re
regex = re.compile(r"<(\"[^\"]*?\"|'[^']*?'|[^'\">])*>", flags=re.MULTILINE)
test_str = ("re<br>na<br>to<br>galvao\n\n"
"<div id=\"mainmenu\">\n"
" <ul class=\"menu root\">\n"
" <li class=\"item selected\" title=\"Regex Tester\"><a href=\"/\">Regex Tester</a></li>\n"
" <li class=\"item \" title=\"Community\"><a href=\"/community/\">Community</a></li>\n"
" <li class=\"item \" title=\"Regex Quiz\"><a href=\"/quiz/\">Quiz</a></li>\n"
" <li class=\"item \" title=\"Join us on IRC!\"><a href=\"/irc/\">Join us on IRC</a></li>\n"
" <li class=\"item \" title=\"About & Credit\"><a href=\"/about/\">About & Credit</a></li>\n"
" </ul>\n"
" </div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")