const regex = /<("[^"]*?"|'[^']*?'|[^'">])*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<("[^"]*?"|\'[^\']*?\'|[^\'">])*>', 'gm')
const str = `re<br>na<br>to<br>galvao
<div id="mainmenu">
<ul class="menu root">
<li class="item selected" title="Regex Tester"><a href="/">Regex Tester</a></li>
<li class="item " title="Community"><a href="/community/">Community</a></li>
<li class="item " title="Regex Quiz"><a href="/quiz/">Quiz</a></li>
<li class="item " title="Join us on IRC!"><a href="/irc/">Join us on IRC</a></li>
<li class="item " title="About & Credit"><a href="/about/">About & Credit</a></li>
</ul>
</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}