#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^near\[(.*?)\]\sfar\[\1\]"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"near[2015-12-1] far[2015-12-1] MATCH" & @CRLF & _
"near[2015-12-3] far[2015-12-1] NO MATCH" & @CRLF & _
"near[2015-12-1] far[2014-12-1] NO MATCH" & @CRLF & _
"near[2015-12-3] far[2015-12-3] MATCH" & @CRLF & _
"foo[2015-12-1] bar[2015-12-1] NO MATCH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")