import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^near\\[(.*?)\\]\\sfar\\[\\1\\]";
final String string = "\n\n"
+ "near[2015-12-1] far[2015-12-1] MATCH\n"
+ "near[2015-12-3] far[2015-12-1] NO MATCH\n"
+ "near[2015-12-1] far[2014-12-1] NO MATCH\n"
+ "near[2015-12-3] far[2015-12-3] MATCH\n"
+ "foo[2015-12-1] bar[2015-12-1] NO MATCH";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}