#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\((\d+)\)"
Local $sString = "(g) sdf" & @CRLF & _
"(554)sdf" & @CRLF & _
"() Df" & @CRLF & _
"(434)sdf" & @CRLF & _
"(d) d" & @CRLF & _
"33" & @CRLF & _
"(33)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")