$re = '/^\((\d+)\)/m';
$str = '(g) sdf
(554)sdf
() Df
(434)sdf
(d) d
33
(33)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);